Advisory record · GHSA-pjjw-qhg8-p2p9

aiohttp has vulnerable dependency that is vulnerable to request smuggling

No CVSS score

Published by the GitHub Advisory Database at 27 Nov 2023, 23:15 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
aiohttpPyPI<3.8.63.8.6
Identifiers
GHSA-pjjw-qhg8-p2p9
Weakness (CWE)
CWE-444
Published
27 Nov 2023
Updated
10 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

aiohttp versions before 3.8.6 are affected because they bundle llhttp 8.1.1, which has two request smuggling vulnerabilities. The source gives few details and says the specifics have not been disclosed. Upgrade aiohttp to 3.8.6 or later, which uses llhttp 9 or newer; no workaround is listed.

Written 5 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

No source has published a CVSS score for this record yet.

  • CISA KEV Not listed.
  • EPSS No score.

Timeline

  1. 31 Oct 2026, 14:36 UTC First seen by agentprime
  2. 31 Oct 2026, 14:36 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.