Advisory record · GHSA-phrq-pc6r-f6gh

MantisBT is vulnerable to authentication bypass through the SOAP API on MySQL

CVSS 9.3 CriticalCriticalEPSS 0.018 · 78th percentile

Critical, because:

  • CVSS score 9.3: 9.0 or more.

How we decide what’s critical

Published by the GitHub Advisory Database at 23 Mar 2026, 20:28 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
mantisbt/mantisbtPackagist<2.28.12.28.1
Identifiers
GHSA-phrq-pc6r-f6gh · CVE-2026-30849 · PKSA-cwyv-kt56-ndf5
Weakness (CWE)
CWE-305
Published
23 Mar 2026
Updated
25 Mar 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

MantisBT versions before 2.28.1 running on MySQL or compatible databases are vulnerable to an authentication bypass in the SOAP API caused by improper type checking of the password parameter. An attacker who knows a victim's username can craft a SOAP request to log in as that user without the password and run any API function the account can access. Upgrade to MantisBT 2.28.1 or later; disabling the SOAP API reduces the risk but still exposes account information such as email addresses and real names.

Written 3 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
9.3 Critical 4.0 CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.018, the 78th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:25 UTC First seen by agentprime
  2. 31 Oct 2026, 14:25 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.