Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Containerd (github.com/containerd/containerd/v2 from 2.0.0 before 2.0.13, 2.1.0 before 2.2.9, 2.3.0 before 2.3.6, and 2.4.0 before 2.4.1; and github.com/containerd/containerd before 1.7.36) is vulnerable to unbounded CPU and memory use during image pull. A crafted OCI image index with deeply nested or widely fanned-out descriptors can stall the pull and strain the host, and the attacker only needs the victim to pull a malicious image reference. Upgrade to 2.0.13, 2.2.9, 2.3.6, 2.4.1, or 1.7.36 as applicable. No workaround is listed beyond pulling only trusted images.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 6.9 | Medium | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0036, the 29th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:12 UTC First seen by agentprime
- 31 Oct 2026, 14:12 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-pg57-6jwg-q645
- OSV: GHSA-pg57-6jwg-q645
- github.com/containerd/containerd/security/advisories/GHSA-pg57-6jwg-q645
- nvd.nist.gov/vuln/detail/CVE-2026-53493
- github.com/containerd/containerd/commit/4f5f32636d47f051751065cf824a10da70c619fe
- github.com/containerd/containerd/commit/94e83c14c8aac963e24e28105dab9c9af812a2a8
- github.com/containerd/containerd
- github.com/containerd/containerd/releases/tag/v1.7.36
- github.com/containerd/containerd/releases/tag/v2.0.13
- github.com/containerd/containerd/releases/tag/v2.2.9
- github.com/containerd/containerd/releases/tag/v2.3.6
- github.com/containerd/containerd/releases/tag/v2.4.1