Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Waitress versions before 1.4.0 can parse HTTP requests differently from a front-end proxy when a bare LF is used as a line terminator, which can allow HTTP request smuggling. An attacker able to send crafted requests through a front-end server could smuggle a second request to Waitress. Upgrade to Waitress 1.4.0, which requires CRLF line terminators and returns 400 Bad Request for bare CR or LF.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.1 | High | 3.1 | CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:L/A:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.025, the 85th percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:37 UTC First seen by agentprime
- 31 Oct 2026, 14:37 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-pg36-wpm5-g57p
- OSV: GHSA-pg36-wpm5-g57p
- github.com/Pylons/waitress/security/advisories/GHSA-pg36-wpm5-g57p
- nvd.nist.gov/vuln/detail/CVE-2019-16785
- github.com/Pylons/waitress/commit/8eba394ad75deaf9e5cd15b78a3d16b12e6b0eba
- access.redhat.com/errata/RHSA-2020:0720
- docs.pylonsproject.org/projects/waitress/en/latest/#security-fixes
- github.com/Pylons/waitress
- github.com/pypa/advisory-database/tree/main/vulns/waitress/PYSEC-2019-136.yaml
- lists.debian.org/debian-lts-announce/2022/05/msg00011.html
- lists.fedoraproject.org/archives/list/[email protected]/message/GVDHR2DNKCNQ7YQXISJ45NT4IQDX3LJ7
- lists.fedoraproject.org/archives/list/[email protected]/message/LYEOTGWJZVKPRXX2HBNVIYWCX73QYPM5
- www.oracle.com/security-alerts/cpuapr2022.html