Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The mtdowling/jmespath.php package before 2.9.1 can generate and execute attacker-controlled PHP code when the CompilerRuntime is used with an attacker-controlled JMESPath expression. An attacker who can supply the expression string can run arbitrary PHP with the privileges of the PHP process. Upgrade to 2.9.1 or later; until then, disable JP_PHP_COMPILE and avoid using CompilerRuntime with untrusted expressions.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 9.8 | Critical | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0044, the 38th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:24 UTC First seen by agentprime
- 31 Oct 2026, 14:24 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-pcw8-m77r-2528
- OSV: GHSA-pcw8-m77r-2528
- github.com/jmespath/jmespath.php/security/advisories/GHSA-pcw8-m77r-2528
- nvd.nist.gov/vuln/detail/CVE-2026-54133
- github.com/FriendsOfPHP/security-advisories/blob/master/mtdowling/jmespath.php/CVE-2026-54133.yaml
- github.com/jmespath/jmespath.php