Advisory record · GHSA-p8q5-cvwx-wvwp

Flask-AppBuilder Observable Response Discrepancy

CVSS 3.7 LowEPSS 0.0033 · 26th percentile

Published by the GitHub Advisory Database at 3 Mar 2025, 15:26 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
flask-appbuilderPyPI<4.5.34.5.3
Identifiers
GHSA-p8q5-cvwx-wvwp · CVE-2025-24023 · PYSEC-2025-15
Weakness (CWE)
CWE-204
Published
3 Mar 2025
Updated
10 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Flask-AppBuilder versions before 4.5.3 are vulnerable to username enumeration through database authentication. An unauthenticated attacker can repeatedly submit login requests and measure response times to determine which usernames exist. Upgrade to flask-appbuilder 4.5.3 or later. The source also lists downgrading werkzeug to a version below 3.0.0 as a workaround.

Written 5 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
3.7 Low 3.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.0033, the 26th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:37 UTC First seen by agentprime
  2. 31 Oct 2026, 14:37 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.