Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
containerd (Go module github.com/containerd/containerd/v2) versions 2.1.0 up to 2.2.7 and 2.3.0 up to 2.3.4 are affected. A container restored through the CRI CreateContainer API from a crafted checkpoint can run with root and full capabilities, ignoring the requested security context and seccomp settings. Upgrade to containerd 2.2.7 or 2.3.4; on unpatched versions, restrict container creation to trusted users and reject images containing checkpoint data.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.8 | High | 3.1 | CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0011, the 1st percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:11 UTC First seen by agentprime
- 31 Oct 2026, 14:11 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-p7v4-vr35-mj6f
- OSV: GHSA-p7v4-vr35-mj6f
- github.com/containerd/containerd/security/advisories/GHSA-p7v4-vr35-mj6f
- nvd.nist.gov/vuln/detail/CVE-2026-95837
- github.com/containerd/containerd/pull/13913
- github.com/containerd/containerd/commit/928c03c6898cad95f795300281fdff0dbc55a32f
- github.com/containerd/containerd