Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
CometBFT versions 0.38.0 up to but not including 0.38.15 are affected. A node in a network with vote extensions enabled can send a Precommit vote with an invalid validator index, which causes a panic in peers that process it. Upgrade to CometBFT 0.38.15 or later. Vote extensions are disabled by default, and networks that leave them off are not affected.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| Not published | None | 4.0 | CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N | GitHub Advisory Database |
- CISA KEV Not listed.
- EPSS No score.
Timeline
- 31 Oct 2026, 14:46 UTC First seen by agentprime
- 31 Oct 2026, 14:46 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-p7mv-53f2-4cwj
- OSV: GHSA-p7mv-53f2-4cwj
- github.com/cometbft/cometbft/security/advisories/GHSA-p7mv-53f2-4cwj
- github.com/cometbft/cometbft/commit/17d3bb66664cab6d6798c17e27198e15bbac1905
- docs.cometbft.com/v0.38/spec/abci/abci++_basic_concepts
- github.com/cometbft/cometbft
- github.com/cometbft/cometbft/releases/tag/v0.38.15
- nrdax.com/techniques/NRDAX-T0211
- pkg.go.dev/vuln/GO-2024-3259