Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Apache Tika's tika-parser-pdf-module is vulnerable from version 1.13 through 3.2.1, and the tika-parsers package is affected from 1.13 before 2.0.0-ALPHA. An attacker who can supply a crafted PDF containing a malicious XFA file can perform XML External Entity injection, which may allow reading sensitive data or triggering requests to internal or third-party servers. Upgrade tika-parser-pdf-module to 3.2.2; the tika-parsers package is fixed in 2.0.0-ALPHA.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.4 | High | 3.1 | CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H | CNA (apache) |
- CISA KEV Not listed.
- EPSS 0.48, the 98th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:17 UTC First seen by agentprime
- 31 Oct 2026, 14:17 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-p72g-pv48-7w9x
- OSV: GHSA-p72g-pv48-7w9x
- nvd.nist.gov/vuln/detail/CVE-2025-54988
- github.com/apache/tika/pull/2291
- github.com/apache/tika/commit/2b52257304f4d3cde2b8463657380bdb936d9ef2
- archive.apache.org/dist/tika/3.2.2/CHANGES-3.2.2.txt
- github.com/apache/tika
- issues.apache.org/jira/browse/TIKA-4459
- lists.apache.org/thread/8xn3rqy6kz5b3l1t83kcofkw0w4mmj1w
- lists.apache.org/thread/stn9oh7rfn9yv76n1srxr9w56oy04p72
- lists.debian.org/debian-lts-announce/2025/10/msg00030.html
- www.openwall.com/lists/oss-security/2025/08/20/2
- www.openwall.com/lists/oss-security/2025/08/20/3