Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
GHSA-p6wj-qrr4-pgh5 affects the Go package github.com/getkin/kin-openapi versions 0.136.0 up to but not including 0.143.0. A nil-pointer dereference in openapi3filter panics when an OpenAPI 3.1 operation declares an array without `items`, which doesn't fail document validation. An unauthenticated client can trigger the panic with one HTTP request to such an operation, which may crash the process if no recover is in place. Upgrade to version 0.143.0 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.5 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0062, the 49th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:11 UTC First seen by agentprime
- 31 Oct 2026, 14:11 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-p6wj-qrr4-pgh5
- OSV: GHSA-p6wj-qrr4-pgh5
- github.com/getkin/kin-openapi/security/advisories/GHSA-p6wj-qrr4-pgh5
- nvd.nist.gov/vuln/detail/CVE-2026-97394
- github.com/getkin/kin-openapi/commit/30e292371a89ca6d1f91a9553e0aa518b49f838d
- github.com/getkin/kin-openapi
- github.com/getkin/kin-openapi/releases/tag/v0.143.0