Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The npm package next is vulnerable in versions from 13.0.0 up to but not including 15.5.28, and from 16.0.0 up to but not including 16.4.1. An attacker can send crafted requests to an App Router application that has at least one Server Action, causing excessive CPU use that blocks other requests in the same process. Upgrade next to 15.5.28 or 16.4.1; the source says no workaround exists besides upgrading.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.2 | High | 4.0 | CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0039, the 32nd percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 14 Oct 2026, 17:47 UTC Published by the maintainers as a GitHub repository advisory
- 31 Oct 2026, 13:33 UTC First seen by agentprime
- 31 Oct 2026, 13:33 UTC Confirmed by OSV