Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
dbt-core versions 1.6.0 before 1.6.14 and 1.7.0 before 1.7.14 are affected. A materialization defined in an installed package that shares a name with a built-in materialization was preferred by default, so a malicious package could replace dbt's behavior with harmful code. Upgrade to dbt-core 1.6.14, 1.7.14, or 1.8.0 or later. For older versions, set the flag require_explicit_package_overrides_for_builtin_materializations to False in dbt_project.yml to require explicit overrides.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 4.2 | Medium | 3.1 | CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:L | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0037, the 31st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:35 UTC First seen by agentprime
- 31 Oct 2026, 14:35 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-p3f3-5ccg-83xq
- OSV: GHSA-p3f3-5ccg-83xq
- github.com/dbt-labs/dbt-core/security/advisories/GHSA-p3f3-5ccg-83xq
- nvd.nist.gov/vuln/detail/CVE-2024-40637
- github.com/dbt-labs/dbt-core/commit/3c82a0296d227cb1be295356df314c11716f4ff6
- github.com/dbt-labs/dbt-core/commit/87ac4deb00cc9fe334706e42a365903a1d581624
- docs.getdbt.com/docs/build/packages
- docs.getdbt.com/reference/global-configs/legacy-behaviors#behavior-change-flags
- github.com/dbt-labs/dbt-core
- github.com/pypa/advisory-database/tree/main/vulns/dbt-core/PYSEC-2024-66.yaml
- tempered.works/posts/2024/07/06/preventing-data-theft-with-gcp-service-controls
- www.elementary-data.com/post/are-dbt-packages-secure-the-answer-lies-in-your-dwh-policies
- www.equalexperts.com/blog/tech-focus/are-you-at-risk-from-this-critical-dbt-vulnerability