Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Nginx UI versions from 1.9.10-0.20260421071512-7864e378f5cf before 1.9.10-0.20260728074146-a467ed652591 (Go module github.com/0xJacky/Nginx-UI) are affected. An authenticated user can upload a forged encrypted backup to the restore endpoint, overwrite the application config, set nginx command settings, and then run arbitrary commands in the nginx-ui runtime. Upgrade to 1.9.10-0.20260728074146-a467ed652591, which is the fixed version. The source gives no workaround.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 9.4 | Critical | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0057, the 47th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:11 UTC First seen by agentprime
- 31 Oct 2026, 14:11 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-p393-cf76-4jmr
- OSV: GHSA-p393-cf76-4jmr
- github.com/0xJacky/nginx-ui/security/advisories/GHSA-p393-cf76-4jmr
- nvd.nist.gov/vuln/detail/CVE-2026-107806
- github.com/0xJacky/nginx-ui/commit/a467ed652591fc0cd1b466a1ec751b493faef9f7
- github.com/0xJacky/nginx-ui
- github.com/0xJacky/nginx-ui/releases/tag/v2.5.0