Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Excelize (github.com/xuri/excelize/v2) versions from 2.8.1 up to 2.11.1-0.20261003002531-6258dcebc4e2 are affected. An attacker who supplies a crafted .xlsx file containing a malformed pivot table can cause a call to GetPivotTables to panic, which crashes the host process. Upgrade to 2.11.1-0.20261003002531-6258dcebc4e2 or later, or avoid calling GetPivotTables on untrusted workbooks.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.7 | High | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0023, the 14th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:11 UTC First seen by agentprime
- 31 Oct 2026, 14:11 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-mx22-3794-2vpv
- OSV: GHSA-mx22-3794-2vpv
- github.com/qax-os/excelize/security/advisories/GHSA-mx22-3794-2vpv
- nvd.nist.gov/vuln/detail/CVE-2026-107211
- github.com/qax-os/excelize/pull/2435
- github.com/qax-os/excelize/commit/6258dcebc4e2a2aed985c38a08098dfd908521d1
- github.com/qax-os/excelize