Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Backpack CRUD versions 6.0.0 to before 6.8.14 and 7.0.0 to before 7.0.38 are vulnerable to stored cross-site scripting in the color column type, where values are rendered unescaped by default. An attacker who can write an arbitrary string into a color column can run JavaScript in the browser of any user who views the list, including administrators. Upgrade to 6.8.14 or 7.0.38. Until then, validate color values against a strict hex color pattern in the model before they are stored.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 5.4 | Medium | 3.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0031, the 24th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:24 UTC First seen by agentprime
- 31 Oct 2026, 14:24 UTC Confirmed by OSV