Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The AWS Advanced JDBC Wrapper (Maven software.amazon.jdbc:aws-advanced-jdbc-wrapper) versions 3.0.0 up to but not including 4.0.1 are affected. A low-privilege authenticated user can create a crafted function that runs with the permissions of other RDS users, allowing escalation to the rds_superuser role. Upgrade to version 4.0.1. As a workaround, remove the public schema from the search path.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.6 | High | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N | CNA (AMZN) |
- CISA KEV Not listed.
- EPSS 0.0050, the 42nd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:19 UTC First seen by agentprime
- 31 Oct 2026, 14:19 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-mhww-p97m-3368
- OSV: GHSA-mhww-p97m-3368
- github.com/aws/aws-advanced-jdbc-wrapper/security/advisories/GHSA-mhww-p97m-3368
- nvd.nist.gov/vuln/detail/CVE-2026-11400
- aws.amazon.com/security/security-bulletins/2026-039-aws
- github.com/aws/aws-advanced-jdbc-wrapper
- github.com/aws/aws-advanced-jdbc-wrapper/releases/tag/4.0.1
- www.cve.org/cverecord?id=CVE-2026-11400