Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
geopy versions before 2.5.0 are vulnerable to regular expression denial of service through geopy.Point and Point.from_string(), which can consume excessive CPU time when parsing long, malformed coordinate strings. An attacker who can supply such strings to an application, including through geocoder reverse methods, can cause repeated requests to slow or deny service. Upgrade to geopy 2.5.0 or later, which rejects overly long coordinate strings before parsing; as a workaround, limit coordinate string length to about 256 characters before passing input to geopy.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 4.0 | Medium | 3.1 | CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0020, the 10th percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:08 UTC First seen by agentprime
- 31 Oct 2026, 14:08 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-mhvh-fq92-pfmr
- OSV: GHSA-mhvh-fq92-pfmr
- github.com/geopy/geopy/security/advisories/GHSA-mhvh-fq92-pfmr
- nvd.nist.gov/vuln/detail/CVE-2026-77387
- github.com/geopy/geopy/issues/608
- github.com/geopy/geopy/pull/610
- github.com/geopy/geopy/commit/5d09fa843f90ec80788b61552539c9fd3ae6c528
- github.com/geopy/geopy
- github.com/geopy/geopy/releases/tag/2.5.0