Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
github.com/getkin/kin-openapi versions before 0.145.0 panic when the spec loader processes a self-referential additionalProperties $ref, crashing the process. An attacker who can get the loader to process a crafted OpenAPI document can cause a denial of service. Upgrade to 0.145.0. Until then, avoid loading untrusted specs.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 5.3 | Medium | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0037, the 31st percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:12 UTC First seen by agentprime
- 31 Oct 2026, 14:12 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-mh7x-f8wq-4jhx
- OSV: GHSA-mh7x-f8wq-4jhx
- github.com/getkin/kin-openapi/security/advisories/GHSA-mh7x-f8wq-4jhx
- nvd.nist.gov/vuln/detail/CVE-2026-100348
- github.com/getkin/kin-openapi/commit/88aa64c7cbd03ecadbb419c473bdcaa8b0124c6b
- github.com/getkin/kin-openapi
- github.com/getkin/kin-openapi/releases/tag/v0.145.0