Advisory record · GHSA-mg4x-prh7-g4mx

Zend-Captcha Information Disclosure and Insufficient Entropy vulnerability

CVSS 7.5 High

Published by the GitHub Advisory Database at 7 Jun 2024, 22:25 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
zendframework/zend-captchaPackagist>=2.0.0, <2.4.9 || >=2.5.0, <2.5.22.4.9, 2.5.2
Identifiers
GHSA-mg4x-prh7-g4mx · PKSA-kv74-yjnp-pcr9
Weakness (CWE)
CWE-331
Published
7 Jun 2024
Updated
4 Dec 2024

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Zend-Captcha versions from 2.0.0 before 2.4.9 and from 2.5.0 before 2.5.2 are affected. The Word CAPTCHA generator picks its characters with PHP's array_rand(), which relies on weak randomness, so an attacker who can brute-force that random number generation could recover CAPTCHA words. The source gives few details about the exact attack conditions. Upgrade to zend-captcha 2.4.9 or 2.5.2.

Written 4 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
7.5 High 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N GitHub Advisory Database
  • CISA KEV Not listed.
  • EPSS No score.

Timeline

  1. 31 Oct 2026, 14:28 UTC First seen by agentprime
  2. 31 Oct 2026, 14:28 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.