Advisory record · GHSA-mfr5-77xh-9j7h

pypdf has possible infinite loop when cloning dictionaries

CVSS 7.1 HighEPSS 0.0022 · 12th percentile

Published by the GitHub Advisory Database at 30 Oct 2026, 23:12 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
pypdfPyPI<6.21.46.21.4
Identifiers
GHSA-mfr5-77xh-9j7h · CVE-2026-119205
Weakness (CWE)
CWE-835
Published
30 Oct 2026
Updated
30 Oct 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

The pypdf PyPI package is vulnerable in versions before 6.21.4, where cloning or duplicating a DictionaryObject can enter an infinite loop. An attacker who supplies a crafted PDF can trigger this condition, which requires that the dictionary be cloned during processing. The fix is to upgrade to pypdf 6.21.4; if an upgrade is not yet possible, the source suggests applying the changes from pull request #4288.

Written 31 Oct 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
7.1 High 4.0 CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.0022, the 12th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 29 Oct 2026, 21:17 UTC Confirmed by NVD
  2. 31 Oct 2026, 14:07 UTC First seen by agentprime
  3. 31 Oct 2026, 14:07 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.