Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Netty's netty-codec-dns package is vulnerable in versions from 4.2.0.Final up to but not including 4.2.16.Final, and in versions before 4.1.136.Final. A remote attacker can send malicious DNS packets containing invalid domain names, which causes the decoder to leak direct memory on each packet, leading to gradual denial of service. Upgrade to 4.2.16.Final or 4.1.136.Final. The source gives no workaround.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 5.3 | Medium | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0063, the 50th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:17 UTC First seen by agentprime
- 31 Oct 2026, 14:17 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-mfg7-5gfp-c4w3
- OSV: GHSA-mfg7-5gfp-c4w3
- github.com/netty/netty/security/advisories/GHSA-mfg7-5gfp-c4w3
- github.com/netty/netty/pull/17063
- github.com/netty/netty/pull/17065
- github.com/netty/netty/commit/5b68c61f37aa4a3045cba624cbea239655c9003b
- github.com/netty/netty/commit/bb2ff68a1fb71cb4b0eb9a9e17b66c52aff680c6
- github.com/netty/netty
- github.com/netty/netty/releases/tag/netty-4.1.136.Final
- github.com/netty/netty/releases/tag/netty-4.2.16.Final