Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
TinyMCE's media plugin is vulnerable to stored cross-site scripting in the npm, NuGet and Packagist packages tinymce and TinyMCE, in versions 7.9.3 before 7.9.4 and 8.5.1 before 8.9.3. An attacker who can supply content crafted through the data-mce-object attribute can inject scripts that run before sanitization, affecting users of editors with the media plugin enabled. Upgrade to TinyMCE 7.9.4 or 8.9.3 or later, as no official workaround is available.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.5 | High | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0035, the 28th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 13:33 UTC First seen by agentprime
- 31 Oct 2026, 13:33 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-mf2p-h6hf-fcwm
- OSV: GHSA-mf2p-h6hf-fcwm
- github.com/tinymce/tinymce/security/advisories/GHSA-mf2p-h6hf-fcwm
- nvd.nist.gov/vuln/detail/CVE-2026-116675
- github.com/tinymce/tinymce/commit/bd1ab5ef024c648c3f9c0b409e54a6c227c7d8a2
- github.com/tinymce/tinymce
- github.com/tinymce/tinymce/releases/tag/8.9.3
- www.tiny.cloud/docs/tinymce/7/7.9.4-release-notes/#overview
- www.tiny.cloud/docs/tinymce/latest/8.9.3-release-notes/#overview