Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
vLLM versions from 0.10.2 before 0.13.0 are affected. A previous fix for CVE-2025-62164 only disabled the prompt embeds feature by default, so when it is enabled, an attacker who can submit prompt embeds can still cause a denial of service. Upgrade to vLLM 0.13.0, or keep prompt embeds disabled until you can upgrade.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.7 | High | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N | CNA (VulnCheck) |
- CISA KEV Not listed.
- EPSS 0.0064, the 51st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:10 UTC First seen by agentprime
- 31 Oct 2026, 14:10 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-mcmc-2m55-j8jj
- OSV: GHSA-mcmc-2m55-j8jj
- github.com/vllm-project/vllm/security/advisories/GHSA-mcmc-2m55-j8jj
- github.com/vllm-project/vllm/pull/30649
- access.redhat.com/security/cve/CVE-2026-56340
- bugzilla.redhat.com/show_bug.cgi?id=2491060
- github.com/pypa/advisory-database/tree/main/vulns/vllm/PYSEC-2026-250.yaml
- github.com/vllm-project/vllm
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-56340.json
- www.vulncheck.com/advisories/vllm-denial-of-service-via-unvalidated-multimodal-embeddings