Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The openssl-encrypt package before 1.4.0 has a sandbox bypass: the plugin sandbox does not restrict file access through alternative methods such as pathlib.Path and io.open. An attacker who can load a plugin can import pathlib or io to read and write arbitrary files, bypassing the restricted_open controls. Upgrade to version 1.4.0 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.7 | High | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N | CNA (VulnCheck) |
- CISA KEV Not listed.
- EPSS 0.0048, the 41st percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:38 UTC First seen by agentprime
- 31 Oct 2026, 14:38 UTC Confirmed by OSV