Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Next.js versions from 15.0.0 before 15.5.27 and from 16.0.0 before 16.3.8 are affected. Applications that use a root-level catch-all page alongside statically generated or Incremental Static Regeneration routes can have their shared response cache poisoned by a single unauthenticated crafted request, with the source indicating this can lead to cross-user content substitution and persistent denial of service. Upgrade to Next.js 15.5.27 or 16.3.8, which contain fixes.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 6.3 | Medium | 4.0 | CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0024, the 15th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 13:33 UTC First seen by agentprime
- 31 Oct 2026, 13:33 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-mcj8-r9mp-w47p
- OSV: GHSA-mcj8-r9mp-w47p
- github.com/vercel/next.js/security/advisories/GHSA-mcj8-r9mp-w47p
- nvd.nist.gov/vuln/detail/CVE-2026-94484
- github.com/vercel/next.js/commit/52c94abdd2ea5f416f5e8353ea8a2edd3fe311b8
- github.com/vercel/next.js/commit/719e4c67d6e92df60246f95e1d96e2dd60789a52
- github.com/vercel/next.js
- github.com/vercel/next.js/releases/tag/v15.5.27
- github.com/vercel/next.js/releases/tag/v16.3.8