Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
GeoServer (org.geoserver.web:gs-web-app and org.geoserver.main:gs-main) before 2.25.0 has improper URI validation in its XML external entity filtering. An unauthenticated attacker can exploit this XXE flaw to make server-side requests to arbitrary HTTP servers, scan internal networks, and read limited .xsd files. Upgrade to 2.25.0 or later, which uses an allowlist by default; the source also notes that the ENTITY_RESOLUTION_ALLOWLIST system property can add schema locations.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 9.3 | Critical | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:L/A:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0031, the 24th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 15:11 UTC First seen by agentprime
- 31 Oct 2026, 15:11 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-mc43-4fqr-c965
- OSV: GHSA-mc43-4fqr-c965
- github.com/geoserver/geoserver/security/advisories/GHSA-mc43-4fqr-c965
- nvd.nist.gov/vuln/detail/CVE-2024-34711
- docs.geoserver.org/latest/en/user/production/config.html#production-config-external-entities
- github.com/geoserver/geoserver