Advisory record · GHSA-m9gg-hp2v-232j

@grpc/grpc-js: In certain configurations, getAuthContext can return unauthorized certificates as though they were authorized

CVSS 7.4 HighEPSS 0.0022 · 12th percentile

Published by the GitHub Advisory Database at 30 Sept 2026, 15:35 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
@grpc/grpc-jsnpm<1.13.6 || >=1.14.0, <1.14.51.13.6, 1.14.5
Identifiers
GHSA-m9gg-hp2v-232j · CVE-2026-101916
Weakness (CWE)
CWE-295
Published
30 Sept 2026
Updated
30 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

The @grpc/grpc-js package versions below 1.13.6, and versions from 1.14.0 up to but not including 1.14.5, are affected. When server credentials are created with requireClientCertificate set to false, getAuthContext does not separate authorized client certificates from unauthorized ones, so applications that rely on its result for authentication can be led to accept unauthorized certificates. Upgrade to 1.13.6 or 1.14.5. Until then, set requireClientCertificate to true, or for @grpc/grpc-js-xds RBAC, set require_client_certificate to true in the DownstreamTlsContext.

Written 31 Oct 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
7.4 High 3.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.0022, the 12th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 13:34 UTC First seen by agentprime
  2. 31 Oct 2026, 13:34 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.