Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Affected versions of typo3/cms-core and typo3/cms are 9.0.0 up to but not including 9.5.20, and 10.0.0 up to but not including 10.4.6. An attacker who can use an internal verification mechanism to create valid HMAC-SHA1 checksums can inject arbitrary data, which can lead to privilege escalation or remote code execution in some attack chains; the attacker needs a valid backend user session or access to an Extbase plugin or module action, depending on the chain. Upgrade to typo3/cms-core or typo3/cms 9.5.20 or 10.4.6.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.8 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.022, the 82nd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:25 UTC First seen by agentprime
- 31 Oct 2026, 14:25 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-m5vr-3m74-jwxp
- OSV: GHSA-m5vr-3m74-jwxp
- github.com/TYPO3/TYPO3.CMS/security/advisories/GHSA-m5vr-3m74-jwxp
- nvd.nist.gov/vuln/detail/CVE-2016-5091
- nvd.nist.gov/vuln/detail/CVE-2020-15098
- github.com/TYPO3/TYPO3.CMS/commit/85d3e70dff35a99ef53f4b561114acfa9e5c47e1
- github.com/FriendsOfPHP/security-advisories/blob/master/typo3/cms-core/CVE-2020-15098.yaml
- github.com/FriendsOfPHP/security-advisories/blob/master/typo3/cms/CVE-2020-15098.yaml
- github.com/TYPO3/TYPO3.CMS
- typo3.org/security/advisory/typo3-core-sa-2016-013
- typo3.org/security/advisory/typo3-core-sa-2020-008