Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The vm2 command-line tool (npm package vm2, versions below 3.11.7) runs the supplied script with default settings that load relative and absolute require() targets through the host Node.js require(), so the script's module body executes in the host process before sandbox isolation applies. An attacker who can supply a script file that a user runs with the vm2 CLI can execute arbitrary code as that user, with access to the host filesystem, child processes and network. Upgrade vm2 to version 3.11.7 or later, which is the listed fixed version.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 9.3 | Critical | 4.0 | CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H | CNA (VulnCheck) |
- CISA KEV Not listed.
- EPSS 0.0020, the 9th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 13:34 UTC First seen by agentprime
- 31 Oct 2026, 13:34 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-jxxv-8r27-vm4p
- OSV: GHSA-jxxv-8r27-vm4p
- github.com/patriksimek/vm2/security/advisories/GHSA-jxxv-8r27-vm4p
- nvd.nist.gov/vuln/detail/CVE-2026-92950
- github.com/patriksimek/vm2/commit/903017c8a1eae9aba947ec854468b48155e79f86
- github.com/patriksimek/vm2
- github.com/patriksimek/vm2/releases/tag/v3.11.7
- www.vulncheck.com/advisories/vm2-before-3.11.7-sandbox-escape-via-cli-require