Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Wasmtime versions before 24.0.7, from 25.0.0 before 36.0.7, from 37.0.0 before 42.0.2, and 43.0.0 are affected. The advisory concerns a panic when transcoding misaligned component model UTF-16 strings, but the source gives few details on who can trigger it or what else is possible. Upgrade to 24.0.7, 36.0.7, 42.0.2, or 43.0.1 depending on your release line.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 5.9 | Medium | 4.0 | CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:L | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0037, the 30th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:24 UTC First seen by agentprime
- 31 Oct 2026, 14:24 UTC Confirmed by OSV