Advisory record · GHSA-jw8x-6495-233v

scikit-learn sensitive data leakage vulnerability

CVSS 4.7 MediumEPSS 0.0019 · 8th percentile

Published by the GitHub Advisory Database at 6 Jun 2024, 21:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
scikit-learnPyPI<1.5.01.5.0
Identifiers
GHSA-jw8x-6495-233v · CVE-2024-5206 · PYSEC-2024-110
Weakness (CWE)
CWE-921 · CWE-922
Published
6 Jun 2024
Updated
10 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

scikit-learn versions before 1.5.0 are affected, specifically TfidfVectorizer in versions up to and including 1.4.1.post1. TfidfVectorizer stores all training tokens in its stop_words_ attribute, so sensitive values such as passwords or keys present in training data may be retained and exposed to anyone who can access the fitted vectorizer. Upgrade scikit-learn to version 1.5.0 or later.

Written 5 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
4.7 Medium 3.0 CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N CNA (@huntr_ai)
  • CISA KEV Not listed.
  • EPSS 0.0019, the 8th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:35 UTC First seen by agentprime
  2. 31 Oct 2026, 14:35 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.