Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Ironic versions from 17.0.0 up to (but not including) 26.1.7, 27.0.0 through 29.0.5, 30.0.0 through 32.0.1, and 33.0.0 through 35.0.1 are affected by a boot script injection vulnerability. The source gives few details about how an attacker would exploit it or what access they need. Upgrade to 26.1.7, 29.0.6, 32.0.2, or 35.0.2, depending on your release line.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 5.8 | Medium | 3.1 | CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:N/I:H/A:N | CNA (mitre) |
- CISA KEV Not listed.
- EPSS 0.0026, the 18th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:41 UTC First seen by agentprime
- 31 Oct 2026, 14:41 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-jrh2-f5jc-xpgr
- OSV: GHSA-jrh2-f5jc-xpgr
- nvd.nist.gov/vuln/detail/CVE-2026-46447
- bugs.launchpad.net/ironic/+bug/2150624
- github.com/openstack/ironic
- security.openstack.org/ossa/OSSA-2026-017.html
- www.openwall.com/lists/oss-security/2026/06/03/11
- www.openwall.com/lists/oss-security/2026/06/15/9