Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Kimai (Packagist package kimai/kimai) versions before 2.58.0 are affected when deployed from the official Docker image without setting APP_SECRET, because the image ships with a publicly known default value. An unauthenticated attacker who can reach the instance may be able to forge signed cookies and login links and take over accounts, including super_admin, if the username and account ID are known and the account has no active 2FA. Upgrade to 2.58.0 or later, and set APP_SECRET to a unique random value if you run the Docker image.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 9.1 | Critical | 4.0 | CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.013, the 71st percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:25 UTC First seen by agentprime
- 31 Oct 2026, 14:25 UTC Confirmed by OSV