Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The @apostrophecms/import-export npm package, versions before 3.7.0, is affected. An archive can include an update-key property whose value is a MongoDB query operator, such as { $ne: null }, and the import uses that value to match and overwrite an existing document. An attacker needs an authenticated session with import access to the target type, such as the built-in contributor role, and no admin interaction. The source reports that a matched document can be overwritten even when the importer did not specify its identifying field. Upgrade to version 3.7.0 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 5.4 | Medium | 3.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0030, the 22nd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 13:33 UTC First seen by agentprime
- 31 Oct 2026, 13:33 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-jqw5-w6h3-44g6
- OSV: GHSA-jqw5-w6h3-44g6
- github.com/apostrophecms/apostrophe/security/advisories/GHSA-jqw5-w6h3-44g6
- github.com/apostrophecms/apostrophe/commit/9500b8b0e1d630d5e07fbb5fd2c25ed0943845ce
- github.com/apostrophecms/apostrophe/commit/f84fd41cbf6c22eb8d0008fc9c25df1f7130b350
- github.com/apostrophecms/apostrophe
- github.com/apostrophecms/apostrophe/releases/tag/@apostrophecms/[email protected]