Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Vibe-Trading (PyPI package vibe-trading-ai) versions >=0.1.0 and <0.1.7 expose LLM-callable tools that allow command execution, code injection, and server-side request forgery. An attacker who can reach the agent's message endpoint, or who can get the agent to process attacker-controlled content such as a document or web page, can cause the LLM to run arbitrary shell commands, which the source says run as root in the default container. Upgrade to vibe-trading-ai 0.1.7 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.7 | High | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N | CNA (VulnCheck) |
- CISA KEV Not listed.
- EPSS 0.0058, the 47th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:08 UTC First seen by agentprime
- 31 Oct 2026, 14:08 UTC Confirmed by OSV