Advisory record · GHSA-jp4c-xjxw-mgf9

pip Vulnerable to Inclusion of Functionality from Untrusted Control Sphere

CVSS 5.3 MediumEPSS 0.0014 · 3rd percentile

Published by the GitHub Advisory Database at 27 Apr 2026, 15:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
pipPyPI<26.126.1
Identifiers
GHSA-jp4c-xjxw-mgf9 · CVE-2026-6357 · PYSEC-2026-2876
Weakness (CWE)
CWE-829
Published
27 Apr 2026
Updated
10 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

pip versions before 26.1 can run its self-update check after installing wheel files, and that check imports well-known Python module names. An attacker who can get a malicious wheel installed could have it place a module under one of those names, which pip would then import. Upgrade to pip 26.1, which runs the self-update check before wheels are installed. Users should still review package contents before installing them.

Written 5 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
5.3 Medium 4.0 CVSS:4.0/AV:L/AC:L/AT:P/PR:H/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N CNA (PSF)
  • CISA KEV Not listed.
  • EPSS 0.0014, the 3rd percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:34 UTC First seen by agentprime
  2. 31 Oct 2026, 14:34 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.