Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Wagtail (PyPI package wagtail) versions 7.0.9 to before 7.1, 7.1rc1 to before 7.3.4, 7.4rc1 to before 7.4.3, and 8.0rc1 before 8.0rc2 are affected. A CMS user who has the "submit translations" permission can use the Admin API's "copy for translation" endpoint to copy an existing page they do not have edit access to, which lets them view that page's contents. Upgrade to Wagtail 7.0.9, 7.3.4, 7.4.3, or 8.0rc2, depending on the release line in use.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 6.5 | Medium | 3.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N | GitHub Advisory Database |
- CISA KEV Not listed.
- EPSS No score.
Timeline
- 31 Oct 2026, 14:07 UTC First seen by agentprime
- 31 Oct 2026, 14:07 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-jm5p-837g-rv8g
- OSV: GHSA-jm5p-837g-rv8g
- github.com/wagtail/wagtail/security/advisories/GHSA-jm5p-837g-rv8g
- github.com/wagtail/wagtail
- github.com/wagtail/wagtail/releases/tag/v7.0.9
- github.com/wagtail/wagtail/releases/tag/v7.3.4
- github.com/wagtail/wagtail/releases/tag/v7.4.3
- github.com/wagtail/wagtail/releases/tag/v8.0rc2