Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The surrealdb crate versions before 1.1.1 are vulnerable. A client authorized to run queries at the root or namespace level can invoke a custom parameter or function at that level, which triggers a panic that crashes the SurrealDB server and causes a denial of service. Upgrade to surrealdb 1.1.1 or later; until then, limit untrusted users' ability to run SurrealQL queries to the database level.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.1 | High | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N | CNA (VulnCheck) |
- CISA KEV Not listed.
- EPSS 0.0045, the 39th percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 15:18 UTC First seen by agentprime
- 31 Oct 2026, 15:18 UTC Confirmed by OSV