Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The npm package ghost is vulnerable in versions from 6.10.3 up to but not including 6.64.0, due to how it loads theme translation files. An attacker who is an authenticated Administrator can supply a crafted theme to execute arbitrary code on the server. Upgrade ghost to version 6.64.0, which contains the fix.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.6 | High | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N | CNA (VulnCheck) |
- CISA KEV Not listed.
- EPSS 0.0065, the 51st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 13:33 UTC First seen by agentprime
- 31 Oct 2026, 13:33 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-jj74-hc2q-xrvm
- OSV: GHSA-jj74-hc2q-xrvm
- github.com/TryGhost/Ghost/security/advisories/GHSA-jj74-hc2q-xrvm
- nvd.nist.gov/vuln/detail/CVE-2026-105677
- github.com/TryGhost/Ghost/issues/30635
- github.com/TryGhost/Ghost/commit/d2f498694be549074dd5817fd0e8a1371b65df02
- github.com/TryGhost/Ghost
- github.com/TryGhost/Ghost/releases/tag/v6.64.0