Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
GeoServer's gs-web-app and gs-wfs Maven packages are affected in versions from 2.27.0 before 2.27.1, from 2.26.0 before 2.26.3, and below 2.25.7. An unauthenticated attacker who can reach the WFS service can trigger XML external entity processing, which allows reading local files the GeoServer process can access and forcing server-side HTTP requests to internal resources. Upgrade to 2.27.1, 2.26.3, or 2.25.7 depending on your release line.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 9.9 | Critical | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:L/A:L | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.44, the 98th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 15:09 UTC First seen by agentprime
- 31 Oct 2026, 15:09 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-jj54-8f66-c5pc
- OSV: GHSA-jj54-8f66-c5pc
- github.com/geonetwork/core-geonetwork/security/advisories/GHSA-2p76-gc46-5fvc
- github.com/geoserver/geoserver/security/advisories/GHSA-jj54-8f66-c5pc
- github.com/geotools/geotools/security/advisories/GHSA-826p-4gcg-35vw
- nvd.nist.gov/vuln/detail/CVE-2025-30220
- github.com/geonetwork/core-geonetwork/pull/8757
- github.com/geonetwork/core-geonetwork/pull/8803
- github.com/geonetwork/core-geonetwork/pull/8812
- docs.geoserver.org/latest/en/user/production/config.html#production-config-external-entities
- github.com/geoserver/geoserver