Advisory record · GHSA-jhm9-h84h-rw83

phpBB Server-Side Request Forgery Vulnerability

CVSS 5.8 MediumEPSS 0.0097 · 61st percentile

Published by the GitHub Advisory Database at 24 May 2022, 17:26 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
phpbb/phpbbPackagist>=3.2.0, <3.2.10 || >=3.3.0, <3.3.13.2.10, 3.3.1
Identifiers
GHSA-jhm9-h84h-rw83 · BIT-phpbb-2020-8226 · CVE-2020-8226 · PKSA-fvv8-yym2-vcvr
Weakness (CWE)
CWE-610 · CWE-918
Published
24 May 2022
Updated
6 Dec 2023

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

phpbb/phpbb versions 3.2.0 before 3.2.10 and 3.3.0 before 3.3.1 are affected by a server-side request forgery flaw in which the remote image dimension check could be used to make the server send requests to arbitrary destinations. The source does not describe the required attacker privileges or the full impact. Upgrade to phpBB 3.2.10 or 3.3.1.

Written 5 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
5.8 Medium 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N GitHub Advisory Database
  • CISA KEV Not listed.
  • EPSS 0.0097, the 61st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:32 UTC First seen by agentprime
  2. 31 Oct 2026, 14:32 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.