Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The k8saudit plugin (versions below 0.18.0) and its cloud variants k8saudit-eks (below 0.12.0), k8saudit-gke (below 0.9.0), k8saudit-aks (below 0.6.0), and k8saudit-ovh (below 0.6.0) did not inspect security settings on initContainers or ephemeralContainers in pod specs. An actor who can create pods could run a privileged container by placing it in one of those lists, which evades the default Create Privileged Pod rule. Upgrade to k8saudit 0.18.0 or the matching cloud variant release (0.12.0, 0.9.0, 0.6.0, or 0.6.0), and review custom image allowlist rules.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 4.3 | Medium | 3.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N | GitHub Advisory Database |
- CISA KEV Not listed.
- EPSS No score.
Timeline
- 31 Oct 2026, 14:12 UTC First seen by agentprime
- 31 Oct 2026, 14:12 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-jhjp-4c2q-xmx4
- OSV: GHSA-jhjp-4c2q-xmx4
- github.com/falcosecurity/plugins/security/advisories/GHSA-jhjp-4c2q-xmx4
- github.com/falcosecurity/plugins/pull/1400
- github.com/falcosecurity/plugins/commit/0adb9b3c7e2c8bad53f30d01c057e038b2afa5e1
- github.com/falcosecurity/plugins
- github.com/falcosecurity/plugins/releases/tag/plugins/k8saudit-aks/v0.6.0
- github.com/falcosecurity/plugins/releases/tag/plugins/k8saudit-eks/v0.12.0
- github.com/falcosecurity/plugins/releases/tag/plugins/k8saudit-gke/v0.9.0
- github.com/falcosecurity/plugins/releases/tag/plugins/k8saudit-ovh/v0.6.0
- github.com/falcosecurity/plugins/releases/tag/plugins/k8saudit/v0.18.0