Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Moodle versions 1.9.x before 1.9.14, 2.0.x before 2.0.5, and 2.1.x before 2.1.2 are affected. The MoodleQuickForm class in the Forms Library does not recognize setConstant operations, so a remote attacker can submit altered values for constant form fields and have unexpected content accepted. Upgrade the moodle/moodle package to 1.9.14, 2.0.5, or 2.1.2, depending on the branch in use.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
No source has published a CVSS score for this record yet.
- CISA KEV Not listed.
- EPSS 0.021, the 81st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:32 UTC First seen by agentprime
- 31 Oct 2026, 14:32 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-jcrj-gmr6-p5j8
- OSV: GHSA-jcrj-gmr6-p5j8
- nvd.nist.gov/vuln/detail/CVE-2011-4301
- github.com/moodle/moodle/commit/1f52e72526c305989eadc702b5299edb2a50ac3c
- github.com/moodle/moodle/commit/2a44c5192c875c4f4b4e813d7227b19d8fda86ba
- github.com/moodle/moodle/commit/a6f18c98f43b6fc6b8b7c4e96af41cb4a626e1b8
- github.com/moodle/moodle/commit/f1f70bd4dde6cd1ea4bdb8ab28fa3d36a53b89d8
- bugzilla.redhat.com/show_bug.cgi?id=747444
- github.com/moodle/moodle
- git.moodle.org/gw?p=moodle.git%3Ba=commit%3Bh=f1f70bd4dde6cd1ea4bdb8ab28fa3d36a53b89d8
- git.moodle.org/gw?p=moodle.git;a=commit;h=f1f70bd4dde6cd1ea4bdb8ab28fa3d36a53b89d8
- moodle.org/mod/forum/discuss.php?d=188313