Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Contao (contao/contao and contao/core-bundle) versions 4.7.0 through 4.7.2 are affected. Confirming an opt-in token does not invalidate previously issued opt-in tokens. The source gives few details about how an attacker would use this or what they could gain. Upgrade to version 4.7.3, which is listed as the fixed version.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 9.8 | Critical | 3.0 | CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H | GitHub Advisory Database |
- CISA KEV Not listed.
- EPSS 0.013, the 69th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:29 UTC First seen by agentprime
- 31 Oct 2026, 14:29 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-j99g-qjvx-995g
- OSV: GHSA-j99g-qjvx-995g
- nvd.nist.gov/vuln/detail/CVE-2019-10643
- github.com/contao/contao/commit/70348cc812b110831ad66a4f9857883f75649b88
- contao.org/en/news.html
- contao.org/en/news/security-vulnerability-cve-2019-10643.html
- github.com/FriendsOfPHP/security-advisories/blob/master/contao/contao/CVE-2019-10643.yaml
- github.com/FriendsOfPHP/security-advisories/blob/master/contao/core-bundle/CVE-2019-10643.yaml