Advisory record · GHSA-j92g-9f8w-j867

PostgreSQL JDBC Driver: Silent channel-binding authentication downgrade via unsupported certificate algorithms

CVSS 8.2 HighEPSS 0.0024 · 14th percentile

Published by the GitHub Advisory Database at 21 Jul 2026, 17:47 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
org.postgresql:postgresqlMaven>=42.7.4, <42.7.1242.7.12
Identifiers
GHSA-j92g-9f8w-j867 · BIT-postgresql-jdbc-driver-2026-54291 · CVE-2026-54291
Weakness (CWE)
CWE-636 · CWE-757
Published
21 Jul 2026
Updated
10 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Versions 42.7.4 through 42.7.11 of the PostgreSQL JDBC driver (org.postgresql:postgresql) can silently downgrade connections that set channelBinding=require from SCRAM-SHA-256-PLUS to plain SCRAM-SHA-256, losing man-in-the-middle protection. An attacker who can intercept the TLS connection can trigger this with a server certificate using an algorithm such as Ed25519, Ed448, or a post-quantum algorithm. Upgrade to 42.7.12 or later; no setting restores enforcement on affected releases, and sslmode=verify-full with a CA-only truststore is an alternative defence.

Written 2 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
8.2 High 4.0 CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:L/SA:N CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.0024, the 14th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:17 UTC First seen by agentprime
  2. 31 Oct 2026, 14:17 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.