Advisory record · GHSA-j3v8-v77f-fvgm

Grav Server-side Template Injection (SSTI) via Denylist Bypass Vulnerability

CVSS 8.8 HighEPSS 0.021 · 81st percentile

Published by the GitHub Advisory Database at 16 Jun 2023, 19:36 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
getgrav/gravPackagist<1.7.421.7.42
Identifiers
GHSA-j3v8-v77f-fvgm · CVE-2023-34253 · PKSA-728s-msrd-5k9y
Weakness (CWE)
CWE-94 · CWE-184 · CWE-1336
Published
16 Jun 2023
Updated
18 Feb 2024

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Grav (getgrav/grav on Packagist) versions before 1.7.42 are vulnerable to server-side template injection through a denylist bypass. An attacker with administrator access, or a non-administrative account that has admin login and page update permissions, can inject Twig templates that run arbitrary PHP functions, which can lead to remote code execution. Upgrade to Grav 1.7.42 or later.

Written 4 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
8.8 High 3.1 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.021, the 81st percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:30 UTC First seen by agentprime
  2. 31 Oct 2026, 14:30 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.