Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
vm2 versions before 3.11.7 are affected when NodeVM's require.external option is enabled and require.root is not explicitly set to a path that excludes node_modules, because modules are then loaded through the real Node.js require() instead of inside the sandbox. Code running inside the sandbox can escape it and execute arbitrary operating system commands on the host. Upgrade the vm2 npm package to 3.11.7, which contains the fix.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 10.0 | Critical | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H | CNA (VulnCheck) |
- CISA KEV Not listed.
- EPSS 0.0078, the 55th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 13:34 UTC First seen by agentprime
- 31 Oct 2026, 13:34 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-j3hm-6rg5-mchv
- OSV: GHSA-j3hm-6rg5-mchv
- github.com/patriksimek/vm2/security/advisories/GHSA-j3hm-6rg5-mchv
- nvd.nist.gov/vuln/detail/CVE-2026-92946
- github.com/patriksimek/vm2/commit/903017c8a1eae9aba947ec854468b48155e79f86
- github.com/patriksimek/vm2
- github.com/patriksimek/vm2/releases/tag/v3.11.7
- www.vulncheck.com/advisories/vm2-before-3.11.7-remote-code-execution-via-require-external