Advisory record · GHSA-j2rp-gmqv-frhv

HashiCorpVault does not correctly validate OCSP responses

CVSS 6.4 MediumEPSS 0.0030 · 23rd percentile

Published by the GitHub Advisory Database at 4 Apr 2024, 18:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
github.com/hashicorp/vaultGo<1.16.01.16.0
Identifiers
GHSA-j2rp-gmqv-frhv · BIT-vault-2024-2660 · CVE-2024-2660 · GO-2024-2690
Weakness (CWE)
CWE-636 · CWE-703
Published
4 Apr 2024
Updated
10 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Vault (github.com/hashicorp/vault) versions before 1.16.0 are affected: the TLS certificates auth method did not correctly validate OCSP responses when one or more OCSP sources were configured. The source does not describe what an attacker needs or what they could do with this flaw. Upgrade to Vault 1.16.0 or later; Vault Enterprise users should move to 1.16.1, 1.15.7, or 1.14.11.

Written 2 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
6.4 Medium 3.1 CVSS:3.1/AV:A/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H CNA (HashiCorp)
  • CISA KEV Not listed.
  • EPSS 0.0030, the 23rd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:15 UTC First seen by agentprime
  2. 31 Oct 2026, 14:15 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.