Advisory record · GHSA-j2hg-w4p4-6rvm

EC-CUBE vulnerable to authorization bypass

CVSS 5.3 MediumEPSS 0.022 · 82nd percentile

Published by the GitHub Advisory Database at 17 May 2022, 04:54 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
ec-cube/ec-cubePackagist>=2.11.0, <2.12.22.12.2
Identifiers
GHSA-j2hg-w4p4-6rvm · CVE-2014-0808 · PKSA-6sn4-mzr6-ydmw
Weakness (CWE)
CWE-566 · CWE-639
Published
17 May 2022
Updated
11 Jun 2024

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

EC-CUBE versions 2.11.0 through 2.12.2 are vulnerable to an authorization bypass caused by a user-controlled key, and EC-Orange systems deployed before June 29, 2015 are also affected. An attacker who is a user of the shopping website can send a crafted HTTP request to obtain other users' information. Upgrade ec-cube/ec-cube to version 2.12.2.

Written 4 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
5.3 Medium 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N GitHub Advisory Database
  • CISA KEV Not listed.
  • EPSS 0.022, the 82nd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:29 UTC First seen by agentprime
  2. 31 Oct 2026, 14:29 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.