Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
LiteLLM versions before 1.83.9 are affected by a server-side request forgery in the LiteLLM Proxy. An attacker holding a valid virtual key can place an api_base inside the user_config request body, which bypasses the existing guard and makes the proxy send requests to a host of their choosing, including internal ones. Upgrade litellm to 1.83.9 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 5.3 | Medium | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0044, the 38th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:09 UTC First seen by agentprime
- 31 Oct 2026, 14:09 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-hx8v-g79f-8w5f
- OSV: GHSA-hx8v-g79f-8w5f
- github.com/BerriAI/litellm/security/advisories/GHSA-hx8v-g79f-8w5f
- nvd.nist.gov/vuln/detail/CVE-2026-59823
- github.com/BerriAI/litellm/pull/25827
- github.com/BerriAI/litellm/commit/47214be317f45a2d2ac08258362e0481411eb427
- github.com/BerriAI/litellm